Unichain - Unichain Mainnet: Transactions are not being included in new blocks – Incident details

All systems operational

Unichain Mainnet: Transactions are not being included in new blocks

Resolved
Major outage
Started 8 days agoLasted about 4 hours

Affected

Unichain Mainnet

Major outage from 2:30 PM to 5:00 PM, Operational from 2:30 PM to 6:30 PM

Public RPC

Major outage from 2:30 PM to 5:00 PM, Operational from 5:00 PM to 6:30 PM

L2 Block Production

Operational from 2:30 PM to 6:30 PM

L1 Batch Posting

Operational from 2:30 PM to 6:30 PM

Node Syncing

Operational from 2:30 PM to 6:30 PM

Unichain Sepolia

Operational from 2:30 PM to 6:30 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. An upgrade to the TEE builder had a poor interaction with our proxy, leading to transactions not being submitted properly.

  • Identified
    Identified

    Many users are reporting that their swaps and transactions are stuck. We have identified an issue with Unichain's proxy where it is not forwarding transactions to our TEE builder.

  • Investigating
    Investigating

    We have noticed that many transactions are getting stuck within Unichain Mainnet's mempool and are subsequently not being added to newly produced blocks. This means user swaps and regular transactions are not being submitted to the chain.